Отправьте заявку

Напишите нам и мы перезвоним в течении 10 минут

Нажимая на кнопку, вы даете согласие на обработку персональных данных и соглашаетесь c политикой конфиденциальности

АРМ Оператора

Отчет “Автоматизированное рабочее место оператора” предназначен для работы с заявками и реализациями за один день для 1С Предприятие 7.7 Комплексная

Вся необходимая информация для работы оператора в одном месте:
  • Остатки товаров на складе
  • Количество заказанного товара
  • Количество отгруженного товара
  • Количество зарезервированного товара
Детализация по
  • заказам
  • отгрузкам
  • резервам
Дополнительные возможности
  • Округлить товар до коробки
  • Исправить количество товара в накладной
Алгоритм работы
1. Проводим все заказы покупателей на выбранную дату
2. Формируем отчет АРМ Оператора
3. Исправляем количество - красные цифры показывают, что товара нет в нужном количестве.
4. Проводим накладные
5. Групповая печать документов

Ускоряем отчет с помощью прямых запросов 1С++

Регистр.Заявки.ДоговорПокупателя = Договор;
    Регистр.Заявки.ЗаявкаПокупателя  = ТекущийДокумент();
    // ресурсы
    Регистр.Заявки.КоличествоРасход = ТаблицаДокумента.Количество;
    Регистр.Заявки.СтоимостьРасход    = ТаблицаДокумента.Сумма;
    // выполняем движение
    Регистр.Заявки.ДвижениеПриходВыполнить();
  1. Добавить строки в Модуль документа РеализацияТоваров
//добавить в ПроведениеПоРегистрам()
Процедура ДвижениеЗаявокПокупателяПростое()
    Если ПустоеЗначение(ДокОснование)=0 Тогда 
        Если ДокОснование.Вид()="ЗаявкаПокупателя" Тогда 
            ВыбратьСтроки();
            Пока ПолучитьСтроку()=1 Цикл
                Регистр.Заявки.Фирма = Фирма;
                Регистр.Заявки.Номенклатура = Номенклатура;         
                Регистр.Заявки.ДоговорПокупателя = Договор;
                Регистр.Заявки.ЗаявкаПокупателя = ДокОснование;
                Регистр.Заявки.КоличествоРасход = Количество;
                Регистр.Заявки.СтоимостьРасход = Сумма;
                Регистр.Заявки.ДвижениеРасходВыполнить();
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Cкачать отчет

СМОТРИТЕ ТАКЖЕ

Показать еще

Если у вас остались вопросы — напишите нам

Делимся опытом, советами и лайфхаками в рассылке

Делимся опытом, советами и лайфхаками в рассылке